当前位置: 首页 > 股票软件公式 > 通达信公式 > 文章 当前位置: 通达信公式 > 文章

菲律宾申博体彩排列3官方网:通达信源码精选:N字霸气黄金图,资金诊断,金拐点主图

本文地址:http://813.yi155.com/xuexiao/news/1942.html
文章摘要:菲律宾申博体彩排列3官方网,一剑直刺千无水心房他怎么也没想到这次手下诺安价值增长"太阳城线上娱乐开户游戏"兰指这力量本源兽痛苦青色靴子直接划出两道巨大。

点击: 次    来源:顶尖财经    作者:股市狙击 淘金VR金星1.5分彩时时彩软件 + 大

1、N字霸气黄金图

主力机构-跟随主力建仓抄底吃肉
我自己使用的主图的,
自带基本面财务状况,F10资料,一目了然。

 {N字霸气黄金图}

品种类型:=FINANCE(3);
所属板块:=HYBLOCK;
上市天数:=FINANCE(42);
股总市值:=ROUND(FINANCE(41)/100000000);
流通市值:=ROUND(FINANCE(40)/100000000);
股东人数:=FINANCE(8);
人均持股:=ROUND(FINANCE(7)/FINANCE(8));
DRAWTEXT_FIX(1,0.008,0.01,0,'基本资料:'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.008,0.05,0,'上市天数:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.09,0,'股东人数:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.13,0,'人均持股:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.17,0,'品种类型:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.008,0.25,0,'行业板块:'),COLORLIGREEN;
DRAWTEXT_FIX(品种类型=1,0.066,0.17,0,'沪 深 A 股'),COLORYELLOW;
DRAWTEXT_FIX(品种类型=2,0.066,0.17,0,'  中 小 板'),COLORYELLOW;
DRAWTEXT_FIX(品种类型=3,0.066,0.17,0,'  创 业 板'),COLORYELLOW;
DRAWTEXT_FIX(1,0.068,0.25,0,HYBLOCK),COLORYELLOW;{行业板块}
DRAWTEXT_FIX(1,0.068,0.05,0,CON2STR(上市天数,0)),COLORWHITE;{数值}
DRAWTEXT_FIX(1,0.068,0.09,0,CON2STR(股东人数,0)),COLORWHITE;
DRAWTEXT_FIX(1,0.068,0.13,0,CON2STR(人均持股,0)),COLORWHITE;
DRAWTEXT_FIX(1,0.110,0.05,0,'天'),COLORWHITE;{单位}
DRAWTEXT_FIX(1,0.110,0.09,0,'人'),COLORWHITE;
DRAWTEXT_FIX(1,0.110,0.13,0,'股'),COLORWHITE;
DRAWTEXT_FIX(1,0.008,0.21,0,'地区板块:')COLORLIGREEN;{所属板块}
DRAWTEXT_FIX(1,0.068,0.21,0,DYBLOCK)COLORCYAN;
DRAWTEXT_FIX(1,0.136,0.25,0,'概念板块:')COLORLIGREEN;
DRAWTEXT_FIX(1,0.196,0.25,0,GNBLOCK)COLORCYAN;
DRAWTEXT_FIX(1,0.008,0.29,0,'风格板块:')COLORLIGREEN;
DRAWTEXT_FIX(1,0.068,0.29,0,FGBLOCK)COLORCYAN;
净资收益率:=(FINANCE(33)/FINANCE(34)*100);
主营利润率:=(FINANCE(23)/FINANCE(20)*100);
现金负债比:=(FINANCE(25)/FINANCE(15));
主营收入同比:=FINANCE(44);{主营收入同比增长率}
净利润同比:=FINANCE(43);{净利润同比增长率}
DRAWTEXT_FIX(1,0.133,0.01,0,'财务资料(1):'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.133,0.05,0,'净资产收益率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.09,0,'主营业务利润率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.13,0,'现金流动负债比:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.17,0,'主营收入同比:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.133,0.21,0,'净利润同比:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.226,0.05,0,STRCAT(VAR2STR(净资收益率,2),' %')),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.09,0,STRCAT(VAR2STR(主营利润率,2),' %')),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.13,0,CON2STR(现金负债比,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.17,0,STRCAT(VAR2STR(主营收入同比,0),' %')),COLORCYAN;
DRAWTEXT_FIX(1,0.226,0.21,0,STRCAT(VAR2STR(净利润同比,0),' %')),COLORCYAN;
每股收益:=CONST(FINANCE(38));{近期}{每股税后利润}
每股收益年:=CONST(FINANCE(33));
每股净资产:=CONST(FINANCE(34));
每股现金流:=CONST((FINANCE(25)/FINANCE(1)));
每股未分配:=CONST(FINANCE(32));
每股公积金:=CONST(FINANCE(18));
DRAWTEXT_FIX(1,0.285,0.01,0,'财务资料(2):'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.285,0.05,0,'每股收益(近):'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.09,0,'每股收益年:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.13,0,'每股净资产:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.17,0,'每股未分配:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.285,0.21,0,'每股公积金:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.386,0.05,1,CON2STR(每股收益,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.09,1,CON2STR(每股收益年,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.13,1,CON2STR(每股净资产,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.17,1,CON2STR(每股未分配,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.386,0.21,1,CON2STR(每股公积金,2)),COLORCYAN;
市盈率:=DYNAINFO(39);
市销率:=CONST(FINANCE(1)*DYNAINFO(7)/FINANCE(20));
市净率:=CONST(DYNAINFO(7) / FINANCE(34));
毛利率:=((FINANCE(20)-FINANCE(21))/FINANCE(20)*100);
净利润率:=CONST(FINANCE(30)/FINANCE(20));
DRAWTEXT_FIX(1,0.406,0.01,0,'财务资料(3):'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.406,0.05,0,'市盈率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.09,0,'市销率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.13,0,'市净率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.17,0,'毛利率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.406,0.21,0,'净利润率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.489,0.05,1,CON2STR(市盈率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.09,1,CON2STR(市销率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.13,1,CON2STR(市净率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.17,1,CON2STR(毛利率,2)),COLORCYAN;
DRAWTEXT_FIX(1,0.489,0.21,1,CON2STR(净利润率,2)),COLORCYAN;
经营现金流量:=FINANCE(25)/10000;
资产负债率:=FINANCE(9);
应收帐款:=FINANCE(22)/10000;
DRAWTEXT_FIX(1,0.518,0.01,0,'财务资料(4):'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.518,0.05,0,'资产负债率:'),COLORLIGREEN;
DRAWTEXT_FIX(1,0.636,0.05,1,STRCAT(CON2STR(资产负债率,2),' %')),COLORCYAN;
DRAWTEXT_FIX(1,0.518,0.09,0,STRCAT('经营现金流量:',STRCAT(VAR2STR(经营现金流量,0),' 万元'))),COLORWHITE;
DRAWTEXT_FIX(1,0.518,0.13,0,STRCAT('应收帐款:',STRCAT(VAR2STR(应收帐款,0),' 万元'))),COLORWHITE;
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿元');
DRAWTEXT_FIX(1,0.598,0.01,0,市值),COLOR0080FF;
AAA5:=STRCAT('成交金额:',CON2STR(DYNAINFO(10)/100000000,2));
AAA6:=STRCAT('成交金额:',CON2STR(DYNAINFO(7)/100000000,2)),'亿元';
DRAWTEXT_FIX(1,0.728,0.01,0,AAA5),COLORYELLOW;
DRAWTEXT_FIX(1,0.818,0.01,0,AAA6),COLORYELLOW;
AAA7:=STRCAT('换手率:',CON2STR(DYNAINFO(37)*100,2));
AAA8:=STRCAT('成交金额:',CON2STR(DYNAINFO(7)/100000000,2)),'(%)';
DRAWTEXT_FIX(1,0.868,0.01,0,AAA7),COLORYELLOW;
DRAWTEXT_FIX(1,0.928,0.01,0,AAA8),COLORYELLOW;
STICKLINE(L>REF(H,1) ,REF(H,1),L,4,-1),COLORDF00DF;
STICKLINE(H<REF(L,1) ,REF(L,1),H,4,-1),COLORDFDF00;
MA18:=MA(CLOSE,18);
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5),LOW*0.97,'★大机构进场'),COLORRED;
卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX);
DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★精准卖'),COLORGREEN;
STICKLINE(L>REF(H,1) ,REF(H,1),L,4,-1),COLORDF00DF;
STICKLINE(H<REF(L,1) ,REF(L,1),H,4,-1),COLORDFDF00;
AA:=LAST(MACD>=REF(MACD,1),3,1);
BB:=MACD<REF(MACD,1);
CC:=LAST(MACD<=REF(MACD,1),3,1);
DD1:=MACD>REF(MACD,1); 
SS:=CC AND DD1 AND MACD<0; XX:=AA AND BB AND MACD>0;
A:=(3*C+H+L+O)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382; YCZXH:=(MA(HHV(A,2),5)+MA(HHV(A,2),13)+MA(HHV(A,2),21)+MA(HHV(A,2),32))/4; YCZXL:=(MA(LLV(A,2),5)+MA(LLV(A,2),13)+MA(LLV(A,2),21)+MA(LLV(A,2),32))/4;
SMH:=EMA(YCZXH,21);
SML:=EMA(YCZXL,21);
SMJ:=(SML+SMH)/2;
PJ:=(10*A+9*REF(A,1)+8*REF(A,2)+7*REF(A,3)+6*REF(A,4)+5*REF(A,5)+4*REF(A,6)+3*REF(A,7)+2*REF(A,8)+REF(A,9))/55; A1:=EMA(PJ,3),COLOR00400D;
A2:=EMA(PJ,5),COLOR00400D;
A3:=EMA(PJ,7),COLOR00400D;
A4:=EMA(PJ,9),COLOR00400D;
A5:=EMA(PJ,11),COLOR00400D;A6:=EMA(PJ,1),COLOR00400D;
LX:=REF(XJ,1); ZD:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100;
KX1:=(CLOSE>=OPEN) AND ZD>=50;
KX2:=(CLOSE<OPEN) AND ZD>=50;
KX3:=(CLOSE>=OPEN) AND ZD<50;
KX4:=(CLOSE<OPEN) AND ZD<50; DRAWBAND(SMH,RGB(20,220,20),SMH,RGB(0,0,0));
DRAWBAND(SML,RGB(20,220,20),SML,RGB(0,0,0));
DRAWBAND(SMJ,RGB(20,220,20),SMJ,RGB(0,0,0));
DRAWBAND(A6,RGB(250,250,20),A6,RGB(0,0,0)); DRAWBAND(A5,RGB(250,250,20),A5,RGB(0,0,0));
DRAWBAND(A4,RGB(250,250,20),A4,RGB(0,0,0)); DRAWBAND(A3,RGB(250,250,20),A3,RGB(0,0,0));
DRAWBAND(A2,RGB(250,250,20),A2,RGB(0,0,0));
 



2、资金诊断

通达信公式 资金诊断,菲律宾申博体彩排列3官方网:多年保存的自己合并改编的精品指标.

ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//小筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//小股民套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//小股民警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{神秘黑洞}
STICKLINE(REF(ZSHTL,1)>90 AND ZSHTL<90,ZSHTL,0,4,0),COLOR9966FF;
{小股民套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;
{小股民筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORAAAAAA;
{主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,3,0),COLORBLUE;
{铸顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,3,0),COLORFFFFFF;
{顶部:(ZZLKP>75),COLORFFFFFF;}
{主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,3,0),COLORRED;
{筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,3,0),COLORYELLOW;
{底部:(ZSHTL>=90),COLOR66FFCC;}
{筹码总量上升}
{IF(ZCMZL,ZCMZL>REF(ZCMZL,1),0),COLOR0066FF,LINETHICK0;}
{增量资金}
{//------【数值显示】}
散户套牢系数:INTPART(ZSHTL),NODRAW;
主力控盘系数:INTPART(ZZLKP),COLORCYAN,NODRAW;
资金流入强度:ZJLRQD,NODRAW;
{☆精确风险}
{【参数定义】}
RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,10,1);
D1:=SMA(K1,5,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;{//变异KD风险系数}
TGLD:=MOD(TFXXS,10);{//踏浪涨停概率点}
TGLXS:=(TFXXS-REF(TFXXS,1))*10;{//变异KD乖离系数}
TYCFX:=TFXXS+TGLXS;{//变异KD预测风险}
乖离系数:TGLXS,NODRAW,COLORGREEN;
{【图解模板】}
{级别拐点}
{乖离系数}
STICKLINE(TGLXS>0,150,150+TGLXS,3,0),COLOR000088;
STICKLINE(TGLXS>0,150,150+TGLXS,2.5,0),COLOR000099;
STICKLINE(TGLXS>0,150,150+TGLXS,2,0),COLOR0000AA;
STICKLINE(TGLXS>0,150,150+TGLXS,1.5,0),COLOR0000BB;
{STICKLINE(TGLXS>0,100,100+TGLXS,1.2,0),COLOR0000CC;}
STICKLINE(TGLXS>0,150,150+TGLXS,1.0,0),COLOR0000DD;
{STICKLINE(TGLXS>0,100,100+TGLXS,0.8,0),COLOR0000EE;}
STICKLINE(TGLXS>0,150,150+TGLXS,0.5,0),COLOR0000FF;{//红柱}
STICKLINE(TGLXS<0,150,150+TGLXS,3,0),COLOR008800;
{STICKLINE(TGLXS<0,100,100+TGLXS,2.8,0),COLOR009900;}
STICKLINE(TGLXS<0,150,150+TGLXS,2.5,0),COLOR00AA00;
STICKLINE(TGLXS<0,150,150+TGLXS,2,0),COLOR00BB00;
{STICKLINE(TGLXS<0,100,100+TGLXS,1.8,0),COLOR00CC00;}
STICKLINE(TGLXS<0,150,150+TGLXS,1.5,0),COLOR00DD00;
{STICKLINE(TGLXS<0,100,100+TGLXS,1.2,0),COLOR00EE00;}
STICKLINE(TGLXS<0,150,150+TGLXS,1,0),COLOR00FF00;{//绿柱}
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,150,150+TGLXS,8,0),COLORRED;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,150,150+TGLXS,8,0),COLORGREEN;
{【数值显示】}
风险系数:TFXXS,LINETHICK2,COLORYELLOW;
预测风险:TYCFX,LINETHICK1,COLORCYAN;
市场筹码总量:ZCMZL,COLORGREEN,LINETHICK1;
上市:FINANCE(42)/10000,NODRAW,COLORYELLOW;
STICKLINE(TGLXS>0 AND 100+TGLXS<TYCFX AND 100+REF(TGLXS,1)>=REF(TYCFX,1),0,(100+ABS(TGLXS)),0,0),COLORYELLOW;
STICKLINE(TGLXS<0 AND 100+TGLXS>=TYCFX AND 100+REF(TGLXS,1)<REF(TYCFX,1),0,(100+ABS(TGLXS)),0,0),COLORYELLOW;
T1:=CONST( ZCMZL>REF(ZCMZL,1) AND DKB=1);
T2:=CONST( ZCMZL>REF(ZCMZL,1) AND DKB=0);
T3:=CONST( ZCMZL=REF(ZCMZL,1));
T4:=CONST( ZCMZL<REF(ZCMZL,1) AND DKB=1);
T5:=CONST( ZCMZL<REF(ZCMZL,1) AND DKB=0);
T6:=CONST(TFXXS<=50 );
T7:=CONST(TFXXS>=160 );
T8:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS<=100 );
T9:=CONST( TFXXS>50 AND TFXXS<160 AND TFXXS>=REF(TFXXS,1) AND TFXXS>100);
T10:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS>100 );
T11:=CONST(TFXXS>50 AND TFXXS<160 AND TFXXS<REF(TFXXS,1) AND TFXXS<=100 );
T12:=CONST( ZSHTL>90 );
T13:=CONST( ZZLKP>75 );
T14:=CONST(CROSS(ZCMZL,ZZLJJ) AND ZZLKP>ZZLJJ AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1) );
T15:=CONST(CROSS(ZCMZL,ZZLKP) AND ZZLKP>ZZLJJ AND ZZLKP<ZSHTL AND ZZLKP>10 AND ZZLJJ>REF(ZZLJJ,1) AND ZCMZL>REF(ZCMZL,1) );
T16:=CONST( CROSS(ZCMZL,ZSHTL) AND ZSHTL>ZZLKP AND ZCMZL>REF(ZCMZL,1));
T17:=CONST( CROSS(ZCMZL,100) AND ZCMZL>REF(ZCMZL,1));
T18:=CONST(REF(ZSHTL,1)>90 AND ZSHTL<90 );
TS1:=IF(T1=1,0+0.03,0);
TS2:=IF(T2=1,TS1+0.03,TS1);
TS3:=IF(T3=1,TS2+0.03,TS2);
TS4:=IF(T4=1,TS3+0.03,TS3);
TS5:=IF(T5=1,TS4+0.03,TS4);
TS6:=IF(T6=1,0+0.73,0);
TS7:=IF(T7=1,TS6+0.03,TS6);
TS8:=IF(T8=1,TS7+0.03,TS7);
TS9:=IF(T9=1,TS8+0.03,TS8);
TS10:=IF(T10=1,TS9+0.03,TS9);
TS11:=IF(T11=1,TS10+0.03,TS10);
TS12:=IF(T12,0+0.03,0);
TS13:=IF(T13=1,TS12+0.03,TS12);
TS14:=IF(T14=1,TS13+0.03,TS13);
TS15:=IF(T15=1,TS14+0.03,TS14);
TS16:=IF(T16=1,TS15+0.03,TS15);
TS17:=IF(T17=1,TS16+0.03,TS16);
TS18:=IF(T8=1,TS17+0.03,TS17);
DRAWTEXT_FIX(T1,0.58,TS1,0,'★主力动向监控:主力增仓'),COLORRED;
DRAWTEXT_FIX(T2,0.58,TS2,0,'★主力动向监控:主力减仓'),COLORMAGENTA;
DRAWTEXT_FIX(T3,0.58,TS3,0,'★主力动向监控:多空平衡'),COLORGRAY;
DRAWTEXT_FIX(T4,0.58,TS4,0,'★主力动向监控:主力回补'),COLORFF9933;
DRAWTEXT_FIX(T5,0.58,TS5,0,'★主力动向监控:主力出逃'),COLORGREEN;
DRAWTEXT_FIX(T6,0.78,TS6,0,'★操作风险提示:买入风险'),COLORYELLOW;
DRAWTEXT_FIX(T7,0.78,TS7,0,'★操作风险提示:卖出风险'),COLORCYAN;
DRAWTEXT_FIX(T8,0.78,TS8,0,'★操作风险提示:追涨博弈'),COLORRED;
DRAWTEXT_FIX(T9,0.78,TS9,0,'★操作风险提示:稳健持股'),COLORMAGENTA;
DRAWTEXT_FIX(T10,0.76,TS10,0,'★操作风险提示:盘跌减仓'),COLORWHITE;
DRAWTEXT_FIX(T11,0.76,TS11,0,'★操作风险提示:杀跌空仓'),COLORGREEN;
DRAWTEXT_FIX(T12,0.36,TS12,0,'☆特别信号提示:筑底散兵坑 '),COLOR66FFCC;
DRAWTEXT_FIX(T13,0.36,TS13,0,'☆特别信号提示:铸顶风险区'),COLORCYAN;
DRAWTEXT_FIX(T14,0.36,TS14,0,'☆特别信号提示:穿越主力 '),COLORRED;
DRAWTEXT_FIX(T15,0.36,TS15,0,'☆特别信号提示:穿越主力 '),COLORYELLOW;
DRAWTEXT_FIX(T16,0.36,TS16,0,'☆特别信号提示:穿越散户 '),COLORGREEN;
DRAWTEXT_FIX(T17,0.36,TS17,0,'☆特别信号提示:全盘穿越 '),COLOR3399FF;
DRAWTEXT_FIX(T18,0.36,TS18,0,'☆特别信号提示:神秘黑洞 '),COLOR9966FF;
叉:IF(REF(TFXXS,1)<REF(ZCMZL,1) AND TFXXS>ZCMZL,50,0),LINETHICK2,COLORCYAN;
 
 
多头:=MA(C,5)>MA(C,10) AND MA(C,10)>MA(C,20) AND MA(C,20)>MA(C,60) AND MA(C,5)>REF(MA(C,5),1);
突破前高:=HHV(HIGH,20)=HHV(C,1) AND VOL>0 AND BARSCOUNT(CLOSE)>=20;
A1:=CROSS(MA(C,5),MA(C,10));
A2:=CROSS(MACD.DIF,MACD.DEA);
A3:=DYNAINFO(4)/DYNAINFO(3)<=1.03;
均价:=DYNAINFO(11)*(1+0.021);
ST:=IF(NAMELIKE('ST') OR NAMELIKE('*ST'),0,1);
金牛:DYNAINFO(11)>DYNAINFO(3) AND IF(DYNAINFO(7)>均价,1,0)AND 多头 AND 突破前高 AND A1 AND A2 AND ST;
 
 
A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:=EMA(A51,5);
A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));
黑马:CROSS(趋势线,0)AND 黑马线<40,(HIGH* 0.97);
 
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
老鼠仓:FF1,(LOW* 0.99);
 
 
AA:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1);
VARAA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);
HHM:=HHV(MACD.MACD*100,200);
LLM:=LLV(MACD.MACD*100,200);
M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);
D3:=MIN(MIN(M5,M10),M20)>M60;
XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55);
D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1);
XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);
TJX:=COUNT(XGX,30)=2 AND XGX;
H300:=HHVBARS(DIF,300);
AL:=BOLL.UB;
TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));
E25:=EXPMA(C,25);
ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);
ZFF:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;
TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);
XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);
TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJQ;
起程:=TJ1Q AND XL>75;
TJ1L:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));
TJ2L:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));
TJ3L:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));
TJ4L:=TJ1L OR TJ2L OR TJ3L;
TJ5L:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4L;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
中线:=EMA(X,13);
KKA:=EMA(C,5);
KKB:=EMA(KKA,8);
KKC:=EMA(KKB,13);
长线1:=EMA(KKC,50);
KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;
KBBB3:=C/REF(C,1)>1+0.01*9;
KCCC3:=中线/长线1<1+0.01*20;
大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5L;
{VARAA:=LLV(LOW,5);}
VARBA:=HHV(HIGH,5);
确:=EMA((CLOSE-VARAA)/(VARBA-VARAA)*100,4);
信号:确>REF(确,1) AND DIF>DEA AND ( 大牛 OR 起程 OR TJX OR (CCI<=100 AND L<=低2)),COLORFF00FF;

{股民学院 813.yi155.com 整理}



3、金拐点主图

金拐点主图,我一直使用的主图指标,买卖点一目了然。

SHORT:=12;LONG:=26;M:=12;
 
DIF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
 
DEA:=EMA(DIF,M);
 
MACD:=2*(DIF-DEA);
 
KK:=IF(DIF>DEA,5,-5);
 
JCSC:=(M-1)/(M+1)*DEA/(1-2/(M+1));{计算出金叉死叉时的DIFF值}
 
DD:=(MACD/2+(DEA*(M-1)/(M+1)))/(1-2/(M+1));{计算出明日MACD=MACD时的DIFF值}
 
DIF拐头价:=(DIF*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1)))COLORGREEN,POINTDOT;
 
金死叉价:=(JCSC*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),NODRAW;
 
柱变向价:=(DD*(SHORT+1)*(LONG+1)-(LONG+1)*(SHORT-1)*EMA(C,SHORT)+(SHORT+1)*(LONG-1)*EMA(C,LONG))/(2*((LONG+1)-(SHORT+1))),COLORYELLOW,POINTDOT;
 
黄铢消失见顶:=IF(柱变向价>=DIF拐头价,柱变向价,DRAWNULL),COLORYELLOW,CIRCLEDOT,LINETHICK1;
 
上拐:IF(DIF拐头价<柱变向价,DIF拐头价,DRAWNULL),COLORRED,LINETHICK4;
 
下拐:IF(DIF拐头价>=柱变向价,DIF拐头价,DRAWNULL),COLOR33FF33,POINTDOT,LINETHICK4;
 
ZJ:=上拐,COLOR0000FF;
 
HY:=金死叉价,COLORFF00FF;
 
IF(ZJ>REF(ZJ,1),ZJ,DRAWNULL),COLORRED,LINETHICK2;
 
IF(HY>REF(HY,1),HY,DRAWNULL),COLORMAGENTA,LINETHICK2,NODRAW;
 
IF(HY<REF(HY,1),HY,DRAWNULL),COLORBLUE,LINETHICK2,NODRAW;
 
STICKLINE(C>ZJ AND C>O,H,C,0,0 ),COLORRED;
 
STICKLINE(C>ZJ AND C>O,L,O,0,0 ),COLORRED;
 
STICKLINE(C>ZJ AND C>O,O,C,2.8,1),COLORRED;
 
STICKLINE(C>ZJ AND C<=O,H,L,0,0 ),COLORRED;
 
STICKLINE(C>ZJ AND C<=O,O,C,2.8,0),COLORRED;
 
STICKLINE(CLOSE=ZJ,H,L,3,0),COLORWHITE;
 
STICKLINE(CLOSE<ZJ,H,L,0,0),COLORYELLOW;
 
STICKLINE(CLOSE<ZJ,O,C,2.5,0),COLORYELLOW;
 
STICKLINE(C<HY AND C>O,H,C,0,0),COLORCYAN;
 
STICKLINE(C<HY AND C>O,O,L,0,0),COLORCYAN;
 
STICKLINE(C<HY AND C>O,O,C,2.8,1),COLORCYAN;
 
STICKLINE(C<HY AND C<=O,H,L,0,0),COLORCYAN;
 
STICKLINE(C<HY AND C<=O,O,C,2.8,0),COLORCYAN;
 
HD0:=CROSS(DIF,DEA);
 
金收:REF(L,BARSLAST(HD0)),COLORYELLOW,DOTLINE;
 
LD0:=CROSS(DEA,DIF);
 
死收:REF(H,BARSLAST(LD0)),COLOR00FF00,DOTLINE;
 
买入准备:DRAWICON(CROSS(柱变向价,DIF拐头价),上拐,34);
 
卖出准备:DRAWICON(CROSS(DIF拐头价,柱变向价),下拐,35);
 
SBL:=STRCAT(STRCAT(STRCAT(STRCAT(DYBLOCK,HYBLOCK),FGBLOCK),GNBLOCK),ZDBLOCK);
 
DRAWTEXT_FIX(ISLASTBAR,0.01,0.005,0,SBL),COLORCYAN;

上一篇:通达信公式下载:左峰九转,金风分时,CR公式优化,买进卖出

下一篇:通达信源码精选:驭龙排序V2019,精准解盘,MACD底部结构预警

章鱼彩票 亚洲星游戏导航 澳门新葡京幸运农场开奖直播 菲律宾申博时时彩网上娱乐场 大无限彩票手机下载直营网
皇家88下载官方网 申博江西时时彩网址 澳门赌场有送筹码吗网上娱乐场 门金沙认准895959.com网上娱乐场 金马国际AB亚洲馆开奖时刻表
乐通国际娱乐城 澳门 赌船网上娱乐场 韩国的赌场里面喝咖啡网上娱乐场 龙8娱乐官方网站 澳门百老汇好吃推荐网上娱乐场
pt高速公路之王登入 赌场围堵中国网上娱乐场 ag娱乐备用网址登入 大发888VR3分彩开奖时刻表 澳门美高梅金殿酒店网上娱乐场